Beim Update von 8.3 auf 9.1 Datenbank defekt

Filmkatalogprogramm
Post Reply
User avatar
Perry Dhalgren
Passerby
Posts: 6
Joined: Sun Apr 24, 2016 10:45 am

Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by Perry Dhalgren » Thu Nov 09, 2017 8:59 pm

Hallo zusammen,

ich habe gestern von Movienizer 8.3 auf die neue Version 9.1 upgedatet. Nachdem ich 9.1 gestartet hatte, wollte es die Datenbank übernehmen. Leider kam da eine Fehlermeldung, welche ich nicht mehr genau weiß. Die Datenbank wurde als defekt gemeldet und lässt sich jetzt nicht mehr öffnen.

Beim Starten erscheint mehrfach die Meldung "List Index out of bounds (5)". Auch der Versuch, die Datenbank zu reparieren hat keinen Erfolg gebracht.

Kennt jemand vielleicht auch dies Problem und hat eine Lösung parat? Ansonsten müsste ich erstmal wieder auf die alte 8.3 Version zurückgehen und damit erstmal leben. Ist aber nicht optimal.

Danke im Voraus

Perry

talcom
Extra
Posts: 12
Joined: Mon Feb 08, 2016 10:00 am

Re: Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by talcom » Fri Dec 08, 2017 5:00 pm

Hallo Zusammem,

ich hatte ein ähnliches Problem. Ich nutze die Portable Version 8.2 und wollte auf 9.1 gehen. Beim ersten Start führt das Programm eine Migration der Datenbank durch. Dort wird ein Integritätscheck durchgeführt. Dieser schlug fehl. Erst als ich die Option zum Check deaktiviert habe, klappte das Update und ich kann die Datenbank nutzen wie vorher auch.

Es wäre aber schön eine Art Datenbankanalyse oder Reperatur im Programm selbst zu haben. Ich weiß ja jetzt nicht, ob noch immer ein Problem mit der DB besteht, auch wenn 9.1 korrekt derzeit arbeitet.

Hierzu bitte mal Feedback von den Entwicklern! Danke!

@perry: nutzt du die Portable Fassung??

Gruß
Talcom

User avatar
Perry Dhalgren
Passerby
Posts: 6
Joined: Sun Apr 24, 2016 10:45 am

Re: Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by Perry Dhalgren » Sun Dec 10, 2017 5:13 pm

Hallo Talcom,

danke für den Hinweis. Ich nutze die "normale" Version, d.h. nicht portable. Ich werde es mal ausprobieren und mich melden, ob es geklappt hat.

Danke

Perry

User avatar
Perry Dhalgren
Passerby
Posts: 6
Joined: Sun Apr 24, 2016 10:45 am

Re: Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by Perry Dhalgren » Sun Dec 10, 2017 5:29 pm

Habe es gerade mal probiert:

Movienizer 9.1 installiert. Beim ersten öffnen der Datenbank beim Integritätscheck den Haken herausgenommen und die beiden anderen Haken aktiviert gelassen.

Leider keine Besserung, ich bekomme immer noch diverse Fehlermeldungen "List Index out of bounds (5)" und die Datenbank lässt sich auch danach nicht manuell öffnen.

Ich hoffe, es kennt noch jemand eine Lösung. Werde erstmal wieder auf die 8er Version zurückgehen.

Danke

Perry

User avatar
Perry Dhalgren
Passerby
Posts: 6
Joined: Sun Apr 24, 2016 10:45 am

Re: Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by Perry Dhalgren » Sun Dec 10, 2017 5:37 pm

Sorry wenn ich hier so viele Threads öffne, leider kann man seinen alten nicht editieren. PS. jetzt habe ich den Button gefunden zum editieren :shock:

Ich habe das Programm jetzt mal als Administrator geöffnet. Ich konnte daraufhin meine Datenbank ganz normal und ohne Fehlermeldungen öffnen und auch problemlos benutzen.

Kann es mit einem Bug zwischen Windows 10 sowie den Standardnutzer und Movienizer zusammenhängen?

Perry

talcom
Extra
Posts: 12
Joined: Mon Feb 08, 2016 10:00 am

Re: Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by talcom » Mon Dec 11, 2017 12:16 pm

Hmmm... gute Frage. Ich nutze die portable Version unter Win10 und muss nichts mit Admin-Rechten Starten. Lediglich das spezielle BAT Datei zum Aufruf der EXE wird verwendet.

talcom
Extra
Posts: 12
Joined: Mon Feb 08, 2016 10:00 am

Re: Beim Update von 8.3 auf 9.1 Datenbank defekt

Post by talcom » Mon Dec 11, 2017 12:18 pm

Perry Dhalgren wrote:
Sun Dec 10, 2017 5:29 pm
Habe es gerade mal probiert:

Movienizer 9.1 installiert. Beim ersten öffnen der Datenbank beim Integritätscheck den Haken herausgenommen und die beiden anderen Haken aktiviert gelassen.

Leider keine Besserung, ich bekomme immer noch diverse Fehlermeldungen "List Index out of bounds (5)" und die Datenbank lässt sich auch danach nicht manuell öffnen.

Ich hoffe, es kennt noch jemand eine Lösung. Werde erstmal wieder auf die 8er Version zurückgehen.

Danke

Perry
Die Meldung hatte ich auch, aber sagt natürlich einem nicht Profi nix. Daher hatte ich in dem vorherigen Beitrag angeregt, Datenbankprüfungen generell mit in das Programm mit aufzunehmen. Dann könnte auf Fehler oder Unstimmigkeiten hingewiesen werden bzw. diese korrigiert werden.

Post Reply